VLC Player 2.1.0 Final for Mac Released, Officially Drops PowerPC Support

Player now requires Snow Leopard or later, goes 64-bit starting now

By Filip Truta on September 26th, 2013 08:09 GMT

Mac users reaping the benefits of VLC Media Player may be interested to know that VideoLAN has decided to drop support for certain Mac configurations. That is, if you were planning to install the new 2.1.0 release.

Officially debuted for Mac, Windows, and Linux this week, VLC Media Player 2.1.0 delivers a truckload of changes (mostly under the hood), including platform-specific tweaks and code corrections.

Most important for Mac users is the discontinued support for PowerPC processors, which means G4 and G5 users are officially being left out in the cold starting with VLC 2.1.0.

Also worth noting on the Mac front, VLC now requires OS X 10.6 (Snow Leopard) or a newer version of Apple’s desktop operating system. All official builds starting now will be 64-bit only too.

VideoLAN has included numerous Interface tweaks for Mac users, and the translations have been updated as well. As usual, you can get the full scoop by visiting the VLC Media Player 2.1.0 changelog.

Download VLC Media Player for Mac OS X (Free)
VLC Media Player icon
   VLC Media Player icon
MORE ON THIS TOPIC
LATEST NEWS
HOT RIGHT NOW

Comments