NVIDIA Upgrades Legacy Driver to Work with Everything Below GeForce 600

This is the best driver to have if you sport an old NVIDIA video card

By Silviu Stahie on December 11th, 2013 15:51 GMT

NVIDIA has just announced the immediate availability for download of the 304.117 Legacy version of its graphics driver for Linux operating systems.

NVIDIA is still providing upgrades for the old graphic cards, although you shouldn’t expect too many improvements. This is still a legacy release, but it's a newer one, in the 304.x branch.

According to the developers, support has been added for the X.org xserver ABI 15 (xorg-server 1.15), which is actually very good news for the users of old video cards.

It's unlikely that NVIDIA will continue with this X.org xserver support for the next stable version, but we can only hope. The driver should work with everything below GeForce 600 series, down to the GeForce 6 Series.

Check out the changelog for a complete list of supported video cards.

Download NVIDIA Display Driver 304.117 for Linux 64-bit

Download NVIDIA Display Driver 304.117 for FreeBSD

Download NVIDIA Display Driver 304.117 for Solaris
NVIDIA logo
   NVIDIA logo
MORE ON THIS TOPIC
LATEST NEWS
HOT RIGHT NOW

Comments