Linux Kernel (Oneiric Backport) Vulnerabilities Fixed in Ubuntu 10.04 LTS

Users can update their operating system to get rid of the problem

By on April 4th, 2013 19:21 GMT

Security vulnerabilities that have been discovered in the Linux kernel packages, this time affecting the Ubuntu 10.04 LTS (Lucid Lynx) operating system, have been announced by Canonical.

According to Canonical, several security issues have been fixed in the kernel.

For example, it has been discovered that in the Linux kernel signal, handlers could leak address information, making it possible to bypass ASLR (Address Space Layout Randomization). A local user could have used this flaw to bypass ASLR, to reliably deliver an exploit payload that would otherwise be stopped.

The security flaws can be fixed if you upgrade your system(s) to the proper version of Linux kernel, detailed in the official announcement.

Don't forget to reboot your computer after the upgrade!

ATTENTION: Due to an unavoidable ABI change, the kernel packages have a new version number, which will force you to reinstall and recompile all third-party kernel modules you might have installed. Moreover, if you use the Linux-restricted-modules package, you have to update it as well to get modules that work with the new Linux kernel version.
Ubuntu 10.04 LTS desktop
   Ubuntu 10.04 LTS desktop
MORE ON THIS TOPIC
LATEST NEWS
HOT RIGHT NOW

Comments