CUPS 1.5.3 Has Improved USB Backend

A lot of updates and changes made their way into this version

By on May 16th, 2012 14:30 GMT

CUPS, a software used to print form applications and to convert the page descriptions produced by applications into something a printer can understand, is now at version 1.5.3.

Highlights of CUPS 1.5.3:

· USB backend based on libusb 1.0 has been improved;
· Fixes for PostScript, SSL, authenticated printing, and networking issues have been implemented;
· The scheduler crash issue if a PPD file contained an invalid paper size was fixed;
· PostScript auto-configuration now works properly;
· The dnssd backend now prefers IPPS over IP;
· A compile problem with old versions of OpenSSL was fixed;
· Finishing options were not passed to IPP printers issue was fixed;
· Supplies with commas in their names are now reported correctly;
· POSIX ACLs are now set properly on certificate files;
· More supported color names for SNMP supplies have been added;
· The IPP backend's handling of HTTP/1.0 compatibility has been fixed.

A complete changelog can be found in the official announcement.

Download CUPS 1.5.3
right now from Softpedia.

Follow us on Google+
CUPS on Unix
   CUPS on Unix
MORE ON THIS TOPIC
LATEST NEWS
HOT RIGHT NOW

Comments