1 in 5 Macs Still Vulnerable Following OS X 10.9.2 Release

OS X 10.9.2 and accompanying security updates leave Snow Leopard behind

By on February 27th, 2014 14:35 GMT

Apple may have delivered a much needed round of security patches on Tuesday, but that doesn’t mean everyone is safe. Far from it, actually. According to a new report, 1 in 5 Macs out there are still highly susceptible to hacker attacks.

That’s mostly because Apple, without warning, has stopped supplying security patches to its four-year old Mac OS X version 10.6 aka Snow Leopard. Instead, the company just offered the latest security fixes to Lion (OS X 10.7), Mountain Lion (OS X 10.8), and Mavericks (OS X 10.9) customers.

The reason can be anything from prioritizing engineering force to the company’s laid-back attitude towards malware. But one thing is certain: for an OS that still runs on 1 in 5 Macs today, security should remain a top priority.

Computerworld cites Andrew Storms, director of DevOps at security company CloudPassage, as saying in a December interview, “Let's face it, Apple doesn't go out of their way to ensure users are aware when products are going end of life.”

According to the site’s analysis of the problem, all Macs that are running OS X Snow Leopard can be compromised by cybercriminals. And before you jump on the upgrade-or-die bandwagon, keep in mind that Snow Leopard remains one of Apple’s most reliable OS releases to date, if not the most reliable of them all.
Snow Leopard banner
   Snow Leopard banner
MORE ON THIS TOPIC
LATEST NEWS
HOT RIGHT NOW

Comments